無料のオンライン開発ツール
Base64、JSON、URLエンコード、ハッシュ、画像、PDFのブラウザーツール。目的から探し、結果を確認してコピーやダウンロードができます。
Base64エンコード・デコード
Unicodeに対応したBase64変換ツールです。テキストとバイトを変換し、診断内容や出力を確認できます。
Base64エンコーダー
テキストをBase64に変換します。文字コード、MIMEの折り返し、行ごとの処理を選べます。
Base64デコーダー
Base64、Base64URL、Data URIをデコードします。バイナリデータを失わずにテキストと元のバイトを確認できます。
Base64URLエンコード・デコード
トークン、クエリパラメーター、識別子に使える、URLで安全なBase64文字セットで変換します。
画像をBase64に変換
画像をアップロードせずに、HTMLやCSSで使えるBase64やData URIに変換します。
ファイルをBase64に変換
ファイルを端末内でBase64やData URIに変換します。元のバイトをそのまま保持します。
PNG から Base64 へ
PNG 画像の元のバイト列を保ったまま、ローカルで Base64 またはすぐに使える Data URI に変換します。
JPG から Base64 へ
JPG 画像の元のバイト列を保ったまま、ローカルで Base64 またはすぐに使える Data URI に変換します。
WebP から Base64 へ
WebP 画像の元のバイト列を保ったまま、ローカルで Base64 またはすぐに使える Data URI に変換します。
Base64を画像に変換
Base64やData URIから画像の元データを復元します。プレビューを確認してからダウンロードできます。
Base64 から PNG へ
Base64 またはデータ URI から元の png バイトを復元します。ダウンロードする前に結果を確認してください。
Base64 から JPG へ
Base64 またはデータ URI から元の jpg バイトを復元します。ダウンロードする前に結果を確認してください。
Base64 から WEBP
Base64 またはデータ URI から元の webp バイトを回復します。ダウンロードする前に結果を確認してください。
Base64をPDFに変換
Base64やData URIからPDFを復元します。ダウンロード前に文書を解析できるか確認します。
Base64 オーディオ プレーヤー
オーディオ データ URI をデコードし、ローカルで聞いて元のバイトをダウンロードします。
SVG から Base64 へ
SVG のソースから、CSS や HTML で使える Base64 形式またはパーセントエンコード形式の Data URI を作成します。
データ URI インスペクター
アクティブ コンテンツを開かずに、MIME メタデータ、ペイロード エンコーディング、およびデコードされたバイトを検査します。
Base64 バリデーター
アルファベット、パディング、正規のパディング ビット、UTF-8、および検出されたファイル タイプを 1 か所で確認します。
Base64 修復
空白、データ URI プレフィックス、および欠落しているパディングの安全な正規化をプレビューします。不明な文字はエラーのままになります。
変換ワークフロー
小さな操作を繰り返し可能なレシピに結び付けます。各ステップと、変換が失敗する正確な場所を確認してください。
JSON フォーマッタ
すべての数値トークンを保持しながら、JSON を検証、フォーマット、または圧縮します。
JSON 美容師
すべての数値トークンを保持しながら、JSON を検証、フォーマット、または圧縮します。
JSON ミニファイアー
すべての数値トークンを保持しながら、JSON を検証、フォーマット、または圧縮します。
JSON ↔ YAML
構造化データを JSON と YAML の間で変換します。
JSON ↔ CSV
レコードを区切りテキストに変換するか、引用符で囲まれた値を失わずに CSV を解析します。
XML ↔ JSON
XML 属性とテキストを JSON に変換するか、JSON から XML を構築します。
YAML ↔ TOML
YAML と TOML の間で構成データを変換します。
TOML パーサー
TOML を解析するか、符号付き 64 ビット整数を保持したまま JSON から生成します。
JSON ↔ TOML
TOML を解析するか、符号付き 64 ビット整数を保持したまま JSON から生成します。
XML フォーマッタ
順序付けされた属性保持パーサーを使用して、XML をフォーマット、縮小、または検証します。
JSON Pointer
RFC 6901 ポインターとエスケープされたオブジェクト キーを使用して、JSON 値を読み取ります。
JSON Merge Patch
RFC 7396 マージ セマンティクスを適用します。null はメンバーを削除し、配列は配列を置き換えます。
JSON Patch
RFC 6902 の追加、削除、置換、移動、コピー、およびテスト操作を適用します。
JSONPath テスター
正規化されたパスと正確な結果値を使用して、フィルターと標準関数を含む RFC 9535 JSONPath を評価します。
JSON 行コンバーター
JSON 行を配列に変換するか、配列を 1 行につき 1 つの JSON ドキュメントに変換します。
JSON 平坦化と平坦化解除
値をエスケープされた JSON に平坦化して、元に戻せる結果を得るために明示的なコンテナー レコードを持つポインターを作成します。
JSON ~ SQL
数値を四捨五入せずに、JSON レコードからエスケープされた SQL INSERT ステートメントを生成します。
CSV / TSV 転置
引用符で囲まれた区切り文字と複数行のセルを保持したまま、行と列を交換します。
CSV 列エディター
列または行を選択、削除、並べ替え、フィルターし、重複を排除します。
CSV ~ SQL
明示的な列タイプと安全な文字列と識別子のエスケープを使用して SQL を生成します。
CSV ~ HTML テーブル
キャプションとヘッダーを含むエスケープされた HTML テーブルを作成します。
TSV、CSV、JSON コンバーター
セルの種類を推測したり強制したりせずに、表形式のテキストと配列を変換します。
Java プロパティ ↔ YAML
オプションのドットキーのネストを使用して、Java エスケープと継続行を読み取ります。
IN ↔ JSON
グローバル値とセクション値を、繰り返しキーを含む文字列として保持します。
JSON ~ TypeScript
1 つ以上の代表的なサンプルから、ネストされた TypeScript モデルと JSON マッピングを推測します。
JSON から Go へ
1 つ以上の代表的なサンプルから、ネストされた Go モデルと JSON マッピングを推測します。
JSON ~ Java
1 つ以上の代表的なサンプルから、ネストされた Java モデルと JSON マッピングを推測します。
JSON ~ C#
1 つ以上の代表的なサンプルから、ネストされた C# モデルと JSON マッピングを推測します。
JSON ~ Python
1 つ以上の代表的なサンプルから、ネストされた Python モデルと JSON マッピングを推測します。
JSON から Rust へ
1 つ以上の代表的なサンプルから、ネストされた Rust モデルと JSON マッピングを推測します。
JSON ~ Kotlin
1 つ以上の代表的なサンプルから、ネストされた Kotlin モデルと JSON マッピングを推測します。
JSON ~ Swift
1 つ以上の代表的なサンプルから、ネストされた Swift モデルと JSON マッピングを推測します。
JSON ~ Dart
1 つ以上の代表的なサンプルから、ネストされた Dart モデルと JSON マッピングを推測します。
JSON ~ PHP
文字列エスケープと正確な 64 ビット整数を保持する PHP 戻りファイルを生成します。
XML 比較
順序付けられた XML 構造、属性、テキスト、およびオプションのコメントを比較します。
CSS ミニファイアー
CSS を安全に解析して最適化し、文字列と値の意味を保持します。
JavaScript ミニファイアー
提供されたプログラムを実行せずに、Terser で JavaScript を圧縮します。
HTML ミニファイアー
コメントを削除し、安全な HTML 空白を折りたたんで、フォーマット済みのコンテンツをそのまま維持します。
SQL フォーマッタ
方言対応の解析を使用して SQL をフォーマットします。クエリ テキストは決して実行されません。
Markdown ↔ HTML
Markdown を HTML にレンダリングするか、HTML を読み取り可能な Markdown に変換します。
Markdown テーブルジェネレーター
編集可能な CSV から Markdown テーブルを作成します。列の配置を指定でき、縦棒(|)はエスケープされます。
Mermaid ダイアグラム
Mermaid フローチャート、シーケンス、図をローカルでレンダリングし、SVG をダウンロードします。
HTML をプレーン テキストに変換
スクリプトとスタイルのコンテンツを除外しながら、テキストと段落区切りを抽出します。
HTML から Markdown へ
入力リソースをロードせずに、見出し、表、リンク、コードを Markdown に変換します。
HTML から JSX へ
JSX 属性、スタイル オブジェクト、フォームのデフォルトを使用して React コンポーネントを生成します。
Base16 エンコーダおよびデコーダ
UTF-8 テキストまたは正確なバイトを Base16 で変換します。デコードされたバイトを検査してダウンロードします。
Base32 エンコーダーとデコーダー
UTF-8 テキストまたは正確なバイトを Base32 で変換します。デコードされたバイトを検査してダウンロードします。
Base45 エンコーダおよびデコーダ
UTF-8 テキストまたは正確なバイトを Base45 で変換します。デコードされたバイトを検査してダウンロードします。
Base58 エンコーダーとデコーダー
UTF-8 テキストまたは正確なバイトを Base58 で変換します。デコードされたバイトを検査してダウンロードします。
Base91 エンコーダーとデコーダー
UTF-8 テキストまたは正確なバイトを Base91 で変換します。デコードされたバイトを検査してダウンロードします。
Base122 エンコーダーとデコーダー
UTF-8 テキストまたは正確なバイトを Base122 で変換します。デコードされたバイトを検査してダウンロードします。
Base2048 エンコーダーとデコーダー
UTF-8 テキストまたは正確なバイトを Base2048 で変換します。デコードされたバイトを検査してダウンロードします。
Base36 エンコーダーとデコーダー
任意のサイズの整数またはテキスト バイトを英数字 Base36 に変換します。
Base62 エンコーダおよびデコーダ
構成可能な 62 文字のアルファベットでバイトを変換します。
クロックフォード Base32
人間が判読可能な Base32 (オプションのモジュロ 37 チェックサム検証付き)。
Base85 エンコーダーとデコーダー
Adobe ASCII85 (圧縮ゼロ、オプションのドキュメント区切り文字付き)。
ASCII85 エンコーダおよびデコーダ
Adobe ASCII85 (圧縮ゼロ、オプションのドキュメント区切り文字付き)。
Z85 エンコーダー & デコーダー
4 で割り切れるバイト長の場合は ZeroMQ Z85。非表示のパディングやバイトトリミングはありません。
テキストから 16 進数へのコンバーター
明示的なバイト グループ化とロスレス バイナリ ダウンロードを使用して UTF-8 バイトを変換します。
16 進数からテキストへのコンバーター
明示的なバイト グループ化とロスレス バイナリ ダウンロードを使用して UTF-8 バイトを変換します。
バイナリコンバータ
明示的なバイト グループ化とロスレス バイナリ ダウンロードを使用して UTF-8 バイトを変換します。
8進数コンバータ
明示的なバイト グループ化とロスレス バイナリ ダウンロードを使用して UTF-8 バイトを変換します。
2進化10進数
8421、2421、5421、Excess-3、または Gray 桁コードを使用して 10 進数をエンコードします。
Gray コードコンバータ
負でない整数を反映されたバイナリ Gray コードに変換し、逆に変換します。
ベック32 / ベック32m
BIP173 または BIP350 を使用して、チェックサム付き文字列をエンコードし、検証します。
Elias ガンマ コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Elias デルタコーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
エリアス・オメガ・コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Golomb コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Rice コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Exp Golomb コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Fibonacci コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
単項コーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
カンマコーディング
明示的で可逆的なビットレベルのコードワードとチェックされた境界を使用して整数シーケンスをエンコードします。
Morse コードトランスレータ
国際 Morse コードを使用して、文字、数字、および一般的な句読点を翻訳します。
Baudot / ITA2 コード
明示的な文字と数字のシフトを使用してテレプリンターのテキストをエンコードします。
マンチェスターコード
IEEE、Thomas、または差動マンチェスターを使用して、UTF-8 バイトまたはバイナリ ビットをエンコードします。
Hamming エラー修正
オプションの SECDED 全体パリティを使用して、Hamming(7,4) をエンコードして修正します。
デルタエンコーディング
浮動小数点を失わずに、数値の差、XOR デルタ、または ZigZag の差をエンコードします。
Huffman エンコーダーとデコーダー
デコードに必要なモデルを含むポータブルな JSON レコードを使用して、ロスレス コーディングを検討します。
Shannon-Fano エンコーダおよびデコーダ
デコードに必要なモデルを含むポータブルな JSON レコードを使用して、ロスレス コーディングを検討します。
LZ77 エンコーダーとデコーダー
検査可能な出力と明示的な制限を使用して、可逆圧縮または変換を適用します。
ランレングスエンコーダおよびデコーダ
検査可能な出力と明示的な制限を使用して、可逆圧縮または変換を適用します。
Burrows – Wheeler エンコーダおよびデコーダ
検査可能な出力と明示的な制限を使用して、可逆圧縮または変換を適用します。
Move-to-Front エンコーダおよびデコーダ
検査可能な出力と明示的な制限を使用して、可逆圧縮または変換を適用します。
タンストールエンコーダとデコーダ
デコードに必要なモデルを含むポータブルな JSON レコードを使用して、ロスレス コーディングを検討します。
算術エンコーダおよび算術デコーダ
デコードに必要なモデルを含むポータブルな JSON レコードを使用して、ロスレス コーディングを検討します。
Quoted-Printable エンコード・デコード
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
UUencode エンコーダおよびデコーダ
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
XXencode エンコーダおよびデコーダ
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
yEnc エンコーダおよびデコーダ
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
BinHex 4.0 エンコーダーおよびデコーダー
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
バブルバブルエンコーダ&デコーダ
UTF-8 またはファイル バイトを相互運用可能なレガシー形式でエンコードし、デコードされたデータを検証します。
ROT13 / ROT47
テキストパズル用の反転可能なキャラクター回転。これは暗号化ではありません。
インテル HEX
ファームウェア レコード、拡張アドレス、チェックサムを作成して検証します。
Motorola S-Record
S1、S2、または S3 レコードをエンコードし、アドレス範囲とチェックサムを検証します。
Soundex 音声エンコーダー
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
洗練された Soundex 音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
Metaphone 音声エンコーダー
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
ダブル Metaphone 音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
Nysiis 音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
キャバフォン音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
ケルン音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
Daich Mokotoff 音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
一致評価音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
Phonex 音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
カナダ統計局音声エンコーダ
名前の発音一致コードを計算します。同一性や正確な発音を主張せずにコードを比較します。
NATO 表音文字コンバーター
明示的なトランスポート マーカーを通じて句読点と正確な空白を保持しながら、ラテン文字と数字を綴ります。
MD5 ハッシュ
正確な UTF-8 バイト、16 進数または Base64 バイトから MD5 を計算します。
SHA-1 ハッシュ
正確な UTF-8 バイト、16 進数または Base64 バイトから SHA-1 を計算します。
SHA-256 ハッシュ
正確な UTF-8 バイト、16 進数または Base64 バイトから SHA-256 を計算します。
SHA-512 ハッシュ
正確な UTF-8 バイト、16 進数または Base64 バイトから SHA-512 を計算します。
HMAC ジェネレーター
HMAC と明示的なキー エンコーディングを使用してメッセージ バイトを認証します。
CRC32 チェックサム
テキストまたはファイル バイトの標準 IEEE CRC32 チェックサムを計算します。
ハッシュ識別子
長さだけから独自のアルゴリズムを主張することなく、可能なハッシュ形式を特定します。
ファイルハッシュとチェックサム計算ツール
ファイル チャンクを MD5、SHA-1、SHA-256、または SHA-512 にストリーミングし、予想されるチェックサムを比較します。
AES暗号化と復号化
新しいソルトと IV を使用して暗号化するか、互換性のある AES-GCM/CBC エンベロープをローカルで復号化します。
パスワードジェネレーター
カスタム文字グループを使用して、公平な暗号学的にランダムなパスワードを生成します。
JWT デコーダ
ヘッダー、ペイロード、タイムスタンプを検査します。デコードだけでは署名は検証されません。
TOTP および HOTP ジェネレーター
RFC 4226/6238 ワンタイム パスワードを生成し、otpauth URI をインポートまたは構築します。
BIP39 ニーモニックジェネレーター
BIP39 ニーモニックを生成または検証し、エントロピーを検査して、そのシードをローカルで派生します。
ASCII アーマー
CRC24 を使用して PGP スタイルの ASCII アーマーでバイトをラップするか、デコードしてチェックサムを検証します。
HTTP 基本認証
UTF-8 Basic Authorization ヘッダーを構築してデコードします。パスワード内のコロンを保持します。
SSL証明書デコーダ
信頼を主張することなく、X.509 証明書、名前、有効性、拡張子、およびフィンガープリントを解析します。
証明書署名要求(CSR)デコーダー
PKCS#10 署名リクエストを検査し、その所有証明署名を検証します。
bcrypt ジェネレータおよびベリファイア
bcrypt ハッシュを生成または検証し、72 バイトの bcrypt 制限を超えるパスワードを拒否します。
scrypt キーの導出
明示的なパラメーターを使用して scrypt キーを導出および検証し、移植可能な JSON レコードを完成させます。
Argon2 ジェネレータおよびベリファイア
有界メモリを使用して Argon2id、Argon2i、または Argon2d バージョン 19 の PHC ハッシュを生成および検証します。
オフラインパスワードの強度
ローカル辞書、パターン マッチング、およびオプションの個人的なコンテキストを使用して、推測の難易度を推定します。
NTパスワードハッシュ
従来の NT ハッシュを、正確な UTF-16LE コード単位の MD4 として計算します。
HKDF 抽出と展開
RFC 5869 キー マテリアルを取得するか、抽出を実行して個別に展開します。
PBKDF2 ジェネレータおよびベリファイア
明示的なハッシュと反復回数を使用して PBKDF2 キーを導出するか、完全な JSON レコードを検証します。
PEM / DER コンバーター
型指定された PEM ブロックと正確な DER バイトを変換し、複数のブロックを ZIP としてまとめてダウンロードします。
JWK / PEM コンバーター
デフォルトでは、RSA、EC、Ed25519、および X25519 キーマテリアルをパブリック専用エクスポートで変換します。
OpenPGP キーインスペクター
キーのフィンガープリント、ID、サブキー、有効期限、暗号化状態をローカルで検査します。
OpenPGP 暗号化と復号化
テキストまたはファイルを暗号化し、必要に応じて署名します。正確なバイトを復号化し、署名検証を報告します。
OpenPGP 署名と検証
テキストとファイルの分離、添付、平文の OpenPGP 署名を作成または検証します。
OpenPGP キー ペア ジェネレーター
v4/v6 と有効期限を選択して、ローカル キー ペアと失効証明書を生成します。
XOR バイト
繰り返しキーと明示的なエンコーディングを使用して、正確なバイトを XOR します。
イーサリアムチェックサムバリデーター
Ethereum アドレスを検証し、その EIP-55 大/小文字混合チェックサムを計算します。
サブリソース整合性ジェネレーター
ファイルの正確なバイトをハッシュし、整合性属性またはスクリプト/リンク タグを生成します。
URL エンコーダーとデコーダー
URL コンポーネントまたはフォーム フィールドを Unicode やスペースを含めてエンコードします。
パーセントエンコーディング
RFC 3986 URL コンポーネントまたはすべての UTF-8 バイトをエンコードします。
URL パーサーとビルダー
URL コンポーネントと繰り返しパラメーターを検査するか、フィールドから URL を構築します。
クエリ文字列 ↔ JSON ペア
重複したキー、空の値、パラメータの順序を保持します。
IPアドレスとサブネットの計算ツール
IPv4 または IPv6 を変換し、正確な CIDR 境界を検査します。
ユーザーエージェントパーサー
ユーザー エージェントからブラウザ、オペレーティング システム、デバイス、エンジンの情報を読み取ります。
Robots.txt ジェネレーター
明示的なユーザー エージェントを使用してクローラー ルールを構築し、パスとサイトマップ URL を許可/禁止します。
私のIPは何ですか?
この Web サイトで観測されるパブリック IP とそのおおよその接続メタデータを確認してください。
HAR ビューアとタイムライン
リクエストのタイミングを検査し、リクエストをフィルタリングし、共有する前に共通の秘密を編集します。
HTTP ヘッダー パーサー
資格情報をマスクしながら、繰り返されるヘッダーと HTTP/2 擬似ヘッダーを保持します。
cURL をコードに
単一の Bash cURL コマンドを、実行せずに JavaScript、Python、または Go に変換します。
Cookie および Set-Cookie パーサー
重複した Cookie 名、属性、セキュリティ プレフィックス診断を検査します。
MIME タイプ検索
バンドルされた MIME データベースをファイル名、拡張子、メディア タイプ、またはワイルドカードで検索します。
電子メールヘッダーアナライザー
フィールドを展開し、MIME ワードをデコードし、受信したホップ タイミングを検査します。
電話番号パーサー
オフライン採番メタデータを使用して、国際番号を解析、検証、フォーマットします。
MACアドレスジェネレータ
明示的なアドレス ビットと形式を使用して、暗号的にランダムな MAC アドレスを生成します。
IPv4 範囲拡張器
CIDR または正確な合計と制限されたアドレス リストを含む範囲を拡張します。
IPv6 ULA プレフィックス ジェネレーター
ランダムな 40 ビット グローバル ID と fd00::/8 ローカル /48 および /64 ネットワークを生成します。
CIDR アグリゲータおよびスプリッタ
正確な IPv4/IPv6 カバレッジを結合するか、除外を差し引くか、より小さなサブネットに分割します。
DNS HTTPS の検索
選択したリゾルバーを通じてパブリック DNS をクエリし、応答フラグと TTL を検査します。
安全なリンク デコーダ
ネストされた Microsoft、Proofpoint、Barracuda の宛先を開かずに検査します。
電子メール アドレス ノーマライザー
ローカル部分の大文字と小文字とタグをデフォルトで保持しながら、国際化されたドメインを正規化します。
CSP ビルダー & チェッカー
明示的な診断メッセージを含む Content-Security-Policy ディレクティブを構築または検査します。
タイムスタンプコンバータ
Unix の秒またはミリ秒と ISO 日付を明示的なタイムゾーンで変換します。
エポックコンバーター
Unix エポック秒、ミリ秒、および ISO 8601 の日付を検査します。
クロンパーサー
cron 式を検証し、名前付きタイムゾーンで今後の実行を計算します。
Cron 式ジェネレーター
各フィールドに範囲、ステップ、またはリストを含む 5 フィールドの cron スケジュールを作成します。
カラーコンバーター
CSS カラーを HEX、RGB、HSL、HSV、CMYK 値に変換します。
CSS clamp() ジェネレーター
2 つのビューポート幅の間で流動的な rem/vw フォント サイズ式を計算します。
アスペクト比計算ツール
寸法を正確に単純化し、それに比例した出力高さを計算します。
基数コンバーター
浮動小数点の精度を損なうことなく、基数 2 ~ 36 の符号付き整数を変換します。
バイトコンバーター
ビット、バイト、キロバイト、キビバイトなどの SI と IEC のデータ単位を比較します。
単位換算器
長さ、質量、温度、体積、面積、速度、時間、圧力、エネルギーなどを変換します。
単語&文字カウンター
単語数、Unicode 文字数、読解時間、キーワード密度、英語の読みやすさをカウントします。
テキストラインツール
並べ替え、重複排除、シャッフル、トリム、番号付け、行へのプレフィックスの追加を行います。
Slug ジェネレーター
音訳、Unicode、およびストップワードのオプションを使用して、読み取り可能な URL スラグを作成します。
大文字・小文字変換器
テキストを文、タイトル、ラクダ、パスカル、スネーク、ケバブのケース間で変換します。
デフチェッカー
テキストを行、単語、文字ごとに追加および削除して比較します。
正規表現テスター
時間制限付きで、分離されたワーカーで JavaScript 正規表現をテストします。
ローレム・イプサム・ジェネレーター
ローカルのプレースホルダーの単語、文、または段落を作成します。
レーベンシュタインのユニバーサルコード
非負の整数をプレフィックスのない再帰バイナリ コードとしてエンコードするか、ビットストリームをデコードします。
テキストリストの比較
交差、和集合、または集合の差を使用して、改行で区切られたリストを比較します。
数字から単語へ
浮動小数点の丸めを行わずに、正確な 10 進数の文字列をアメリカ英語またはイギリス英語に変換します。
人民元の金融大文字
正確な人民元の金額を四捨五入せずに中国金融の大文字に変換します。
UUIDジェネレーター
RFC UUID v4 またはタイムスタンプベースの v1 識別子を生成します。
GUIDジェネレーター
RFC UUID v4 またはタイムスタンプベースの v1 識別子を生成します。
UUIDv7 ジェネレーター
タイムスタンプ検査と形式制御を使用して、並べ替え可能な UUIDv7 識別子を作成します。
UUIDデコーダ
UUID のバージョン、バリアント、および埋め込まれた v1、v6、または v7 タイムスタンプを検査します。
Nano ID ジェネレーター
任意の文字集合を使い、暗号学的に安全な乱数によって一様に分布する識別子を生成します。
Snowflake ID の解析・生成
カスタム エポックとビット割り当てを使用して、正確な 64 ビット Snowflake ID を検査または作成します。
MongoDB ObjectId ツール
ObjectId とタイムスタンプ境界をデコード、生成、または構成します。
KSUID ジェネレーターおよびデコーダー
正確な Base62 および 16 進変換を使用して、20 バイトの KSUID 識別子を検査、作成、または構成します。
乱数発生器
オプションの再現可能なシードを使用して、偏りのないランダムな整数または 10 進数値を描画します。
ランダムピッカー
エントリを選択し、リストをシャッフルするか、公平なランダムなグループに分割します。
ランダム決定ホイール
シード可能なランダムな選択を使用して、ローカル リストから勝者を抽出します。
ランダムリストシャッフル
エントリを変更せずに、改行で区切られたリストをシャッフルします。
ランダム文字列ジェネレーター
オプションの決定性シードを使用して文字列サンプルをローカルに生成します。
ランダムな名前ジェネレーター
オプションの決定性シードを使用して名前サンプルをローカルに生成します。
ランダムワードジェネレーター
オプションの決定性シードを使用して単語サンプルをローカルに生成します。
ランダムカラージェネレーター
オプションの決定性シードを使用してカラー サンプルをローカルに生成します。
ランダムな日付ジェネレーター
オプションの決定性シードを使用して、ローカルで日付サンプルを生成します。
ランダムなユーザー名ジェネレーター
オプションの決定性シードを使用してユーザー名サンプルをローカルに生成します。
ランダムメールジェネレーター
予約済みの example.com で安全な架空の電子メール アドレスを作成します。
ランダムアドレスジェネレータ
フォームのテスト用に、明らかに架空のサンプル アドレスを作成します。
ランダムな電話番号ジェネレーター
テスト データ用に予約された架空の北米の電話番号を作成します。
ランダムな国ジェネレーター
オプションの決定性シードを使用して国サンプルをローカルに生成します。
ランダム文字ジェネレーター
オプションの決定性シードを使用して、ローカルで文字サンプルを生成します。
ランダムセンテンスジェネレーター
オプションの決定性シードを使用して文サンプルをローカルに生成します。
ランダムトピックジェネレーター
オプションの決定性シードを使用してトピック サンプルをローカルに生成します。
ランダムな質問ジェネレーター
オプションの決定性シードを使用して質問サンプルをローカルに生成します。
ランダムストーリーキャラクタージェネレーター
オプションの決定性シードを使用してストーリー キャラクター サンプルをローカルに生成します。
ランダムなトランプジェネレーター
オプションの決定性シードを使用してトランプのサンプルをローカルに生成します。
ランダム動物ジェネレーター
オプションの決定性シードを使用して動物サンプルをローカルに生成します。
ランダムオブジェクトジェネレーター
オプションの決定性シードを使用してオブジェクト サンプルをローカルに生成します。
ランダム画像生成器
外部 Picsum イメージ サービスからランダムな写真プレビューを作成します。
ランダムムービージェネレーター
オプションの決定性シードを使用してローカルでムービー サンプルを生成します。
ランダムなタロットカード
創造性を促すために大アルカナのカードを引いてください。
ランダムな聖書の一節
パブリック ドメインの KJV 読み取りリファレンスを選択します。
ランダムなウィキペディアページ
Wikipedia の Special:Random Discovery ページへのリンクを作成します。
ユニコードビューア
Unicode スカラー値、UTF-8 バイト、UTF-16 単位、および書記素を検査します。
JavaScript Unicode エスケープ
コードを評価せずに JavaScript テキストをエスケープまたはエスケープ解除します。
HTML エンティティ エンコーダおよびデコーダ
名前付きまたは数値の HTML エンティティをエンコードし、HTML 文字参照をデコードします。
Punycode ドメインコンバータ
Unicode ラベルと ASCII ラベルの間で国際ドメイン名を変換します。
EBCDICコンバータ
マップ不可能な文字エラーを含む正確な IBM 037、500、875、または 1047 コードページ バイトを変換します。
簡体字・繁体字中国語
OpenCC フレーズ辞書と地域の語彙を使用して中国語を変換します。
Unicode ノーマライザー
コードポイント比較を使用して、Unicode を NFC、NFD、NFKC、または NFKD に正規化します。
不可視文字検出器
幅ゼロの文字、方向制御文字、異常なスペース文字を削除する前に見つけます。
元号日付コンバータ
日本の年号、年齢、学年、干支を正確に変換します。
全角/半角コンバータ
選択されていないテキストを保持しながら、選択した文字クラスを変換します。
ひらがな/カタカナ変換
欧文テキストを変更せずに、濁点付き半角かなを含むかなスクリプトを変換します。
ローマ字コンバータ
ヘボン式、訓令式、日本式、またはパスポートの規則に従って、かな読みを変換します。
文字化け修理
不正な文字デコードから無傷のバイトを回復し、ランク付けされた候補を比較します。
PNG ~ JPG
画像ファイルをローカルで変換し、サイズを変更して、個々の結果または ZIP をダウンロードします。
WebP ~ JPG
画像ファイルをローカルで変換し、サイズを変更して、個々の結果または ZIP をダウンロードします。
JPG ~ PNG
画像ファイルをローカルで変換し、サイズを変更して、個々の結果または ZIP をダウンロードします。
PNG ~ WebP
画像ファイルをローカルで変換し、サイズを変更して、個々の結果または ZIP をダウンロードします。
JPG ~ WebP
画像ファイルをローカルで変換し、サイズを変更して、個々の結果または ZIP をダウンロードします。
画像リサイザ
正確な寸法を設定するか、アスペクト比を維持します。 1 つの画像またはバッチを処理します。
画像圧縮器
選択した品質で画像を再エンコードし、実際の出力サイズを比較します。
画像クロッパー
正確なピクセル座標とオプションのアスペクト比を使用して画像をトリミングします。
画像の回転と反転
完全な寸法を維持しながら、4 分の 1 回転と鏡像で回転します。
画像メタデータ
画像ピクセルを再圧縮せずに、メタデータを検査したり、EXIF、XMP、IPTC、コメントを削除したりできます。
SVG ~ PNG
選択したサイズと DPI で静的な SVG をレンダリングします。アクティブなコンテンツと外部参照は削除されます。
SVG オプティマイザー
ID と viewBox を保持しながら、静的な SVG 座標とマークアップを最適化します。
GIF フレーム ビューア
合成された GIF フレーム、そのタイミングと処理を検査し、フレームを PNG としてエクスポートします。
MP4 ~ MP3
FFmpeg を使用して、ローカルで MP4 ビデオから MP3 オーディオを抽出します。
WebM ~ MP4
FFmpeg を使用してローカルで AAC オーディオを使用して WebM を H.264 MP4 に変換します。
字幕コンバーター
SRT、WebVTT、ASS の間でキュー テキストとタイムスタンプを変換します。
字幕タイムシフター
ASS スタイル フィールドと WebVTT キュー設定を維持しながら、字幕のタイミングをシフトします。
PDF ファイルをマージする
選択した順序で PDF を結合します。元のファイルは変更されません。
PDF ページの分割と抽出
ページ範囲を使用して、ページを新しい PDF に抽出、並べ替え、または繰り返します。
PDF ページを整理する
複数の PDF から選択したページを組み立てます。 file:page 範囲を使用して、ページの並べ替え、挿入、繰り返し、または省略を行います。
PDF への画像
A4、レター、または画像サイズのページで、画像から順番に PDF を作成します。
PDF ページを回転します
テキストをラスタライズしたり、ページ ボックスを変更したりせずに、選択したページを回転します。
PDF を画像に
PDF ページを、選択した解像度で PNG、JPEG、または WebP としてレンダリングします。
PDF 透かし
多言語フォントのサポート、位置、不透明度を備えたテキスト透かしを追加します。
PDF ページ番号
カスタム パターン、埋め込みフォント、および 6 つの位置の選択肢を使用して、選択したページに番号を付けます。
PDF メタデータ
ページをラスタライズせずに、PDF Info および XMP メタデータを検査、編集、または削除します。
PDF を圧縮します
選択した PDF ページをラスタライズし、JPEG として再エンコードします。出力内のテキスト検索とリンクが失われます。
PDF テキストを抽出します
既存のテキストレイヤーを読み取り、必要に応じて行をグループ化し、ページ見出しを追加します。スキャンには別の OCR が必要です。
QRコードジェネレーター
サイズ、色、エラー修正を調整できる QR コードを作成します。
QRコードリーダー
宛先を開かずにローカルで画像から QR コードを読み取ります。
Wi-Fi QRコード
Wi-Fi ネットワーク設定用のスキャン可能な QR コードを作成します。
バーコードジェネレーター
検証済みのチェック ディジットを使用して、Code 128、EAN-13、または UPC-A バーコードを作成します。
一致するツールがありません。
ツールの星マークを押すと、ここに保存できます。
すべてのツールを見る